How To Fix “Exploit Failed” Error while Jailbreaking iOS 6.0.1

How To Fix “Exploit Failed” Error while Jailbreaking iOS 6.0.1 – Apples iOS 6.0.1 firmware has been released recently and there have been many comments about errors that people have been facing trying to jailbreak iOS 6.0.1 with redsn0w. Due to the fact that redsn0w is not yet supporting iOS 6.0.1 until the untethered jailbreak for all iDevices is released, many people are facing the “Exploit Failed” error when jailbreaking the 6.0.1 firmware using the 6.0 IPSW. an easy and simple way to fix the “Exploit Failed” error while using the same program redsn0w.

Fixing Error Required

  • Download the latest Redsn0w redsn0w 0.9.15b3 from here

Supported devices

A4 chip devices only

  • iPhone 4.
  • iPhone 3GS.
  • iPod touch 4th generation.

Note 1: Assuming that most of you have ran into this error and already know the concept of jailbreaking iOS 6.0.1, i will get right to the topic. If not, follow our guide posted here to jailbreak iOS 6.0.1 using redsn0w.

Note 2: The reason for this error occurring is, cause many people are not fully understanding how to enter DFU mode correctly, So you have to know how to put your device in DFU mode correctly.

How To Fix

Note 3: Make sure you are running redsn0w as administrator by right clicking on redsn0w and going to Properties –> Compatibility  mark on “Run this program as an administrator” under Privilege Level.

Also make sure that your USB port drivers are fully upgraded, your USB cable is in good condition, and that you are also on a fresh restored iDevice

How To Fix “Exploit Failed” Error while Jailbreaking iOS 6.0.1

Step 1: Put your device in DFU mode.

You have to take care on this step cause this step is the main reason of the “Exploit Failed” error, you must follow each step correctly.

  • Hold Lock/Power button for 3 seconds.
How To Fix
  • Hold Both Lock/Power and home button for 10 seconds.
How To Fix
  • Keep Holding the Home button for 15 and no less. then release the Power button.(THIS IS THE KEY STEP)
How To Fix
  • DO NOT let the “Home Button“ when the screen changes at 8 seconds, to the picture below.

How To Fix

  • Keep on holding the home button until you see “Uploading first stage” or “Uploading second stage” (Which is about 15-20 seconds) then you can let go of the “Home Button” because the exploit process has finished.

How To Fix

Your Jailbreak should complete Now and the rest of the process will take place on your iDevice.

Note: If you Face “Missing Keys.plist” error, Follow our guide posted here

Please feel free to leave your comments or questions below while following these instructions and We will do our best to help you !

Tmel4198

107 Answers + Add Your Answer

  1. ShadowEvil says:

    I fixed this issue by going back to Beta 1 of Redsn0w… Which works 100%…

  2. Sampson says:

    I have an iphone4 version 6.0.1 and want to jail break but i had this “missing key.plist” error and after finding a solutions and going through the process, when it’s installing Bundles and it reboots instead of the pineapple to show after it reboots it’s rather the apply logo that shows up and my iphone4 comes on to in normal states and the cydia does not install, please i need to pass through this side to be able to jailbreak my phone.

    • Tmel4198 says:

      my solution for missing keys.plist is on this website it works great. Also for your apple logo problem i would recommend that you restore and try the jailbreak instructions for iOS 6.0.1 from my missing keys.plist fix and jailbreak tutorial on this website

    • ShadowEvil says:

      When I ran into this issue… All I did was unplug the Dock Cable from the USB Jack and unplug my iDevice and plug everything back in… Then re-did it. And it worked.

      • Tmel4198 says:

        ya thats what my instructions for the missing keys.plist error say to do haha, glad you figured it out on your own :]

  3. Chetan says:

    Hi i have iPhone 4s with 6.0.1 and i like to jailbreak pls advice bcs without jail break iPhone is so boring

  4. Shane says:

    I’m gettin the “exploit failed” message and im doin all the steps ur saying like hold the home button down for 15 sec. It never pops up to upload 1st stage it just goes straight to “waiting on reboot”. what am i doin wrong???

  5. john says:

    Hi Guys , try this unlock website if you want to unlock your iPhone . It even works for iPhone 5! It’s guaranteed to work 100% . FULL REFUND WILL BE ISSUED IF IPHONE CAN NOT BE UNLOCKED!

    unlockiphones.info

    Admins , kindly dont remove this thread because Im here to help people!

  6. jeanmorcao says:

    i did everythinh you guys said and it still dint work pls help

  7. Gavin says:

    Guys I need help.

    I previously jailbroke my iPhone 4 using this method. It went perfectly. I installed something from cydia and my iphone screwed up so I had to restore it in itunes.

    I’m trying to jailbreak it again, but I keep getting the “exploit failed” message. I’m holding the home button as long as I can and no matter how I put the iPhone in DFU mode it still gives me this error message.

    Please don’t tell me to keep holding the home button I am holding it!

    Any help would be appreciated. Cheers guys!

  8. christina says:

    this worked great as long as i held the home button longer thanks so much

  9. da says:

    i have used this jailbreak and my itunes is not detecting my iphone…also none of the pre-installed apps on the iphone are to be seen…pls help

  10. Shane says:

    Have any of u guys jailbreak an iPad 2 before on ios 6.0.1? ive read many things saying u could and couldnt so curious if any1 has done it before

  11. Blacke says:

    SOLO CAMBIE EL LUGAR DONDE LO CONECTAN POR UNO DE LA PARTE DE ATRAS DEL ORDENADOR, SOLO ESO :)

  12. Jeffrey says:

    It worked! Thank you.

  13. Louis says:

    This really works!!! great job author!

  14. cole says:

    i still get exploit failed shortly after uploading first stage

  15. Anon says:

    For 6.0.1 Users:

    Try right clicking redsn0w.exe, then Run as Administrator.

    Extras > Select IPSW > “Select a 6.0 IPSW”

    If you didn’t try this yet, read the whole thread before complaining.

  16. ACLomby says:

    Hey! thanks a lot! it worked just perfect! (Y)

  17. zazzysoul says:

    I’ve tried multiple times and done about everything it keeps on saying exploit failed, i dont know what to do now

  18. Claudia says:

    I NEED HELP!!! My phone wouldn’t get the wifi signals so I reset the networking settings, then it turned my iPhone 4 off. When it reopened my Jailbreak stuff wasn’t working and I remembered that I have to reboot it. I’ve been trying for 2 hours and nothing is working!!! At first it was the missing file which I fixed with the other post on the site, which brought me to the exploit failed problem. So I try fixing that one and it still doesn’t work! HELP!

  19. I wanted to thank you for this excellent read!! I definitely enjoyed every
    little bit of it. I have you book marked to check out new stuff you post…

  20. jayrag says:

    Hey,I Need help, I can Jailbreak in my Iphone 3gs IOS 6.0.1 but this is not working. and also Email,Maps,Calander,Safari and Cydia this apps not workin please help.

    Jayrag

  21. Hakim says:

    iPhone is really a nice gadget but the only reason it’s not getting market in africa Is that u guys made everything so hard, it’s all about hide and sick with the latest technology forexample when I tried this I lost my data, and music videos, trying to to recover them becoz i made a restore… Am regretting if I had bought Samsung galaxy coz its things a easy with low educated…. Plizzz the company advisers shud style up in considering the whole community as a whole …

  22. RoJr says:

    Thanks a lot! I’ve been stuck weeks trying to jailbreak ios 6.0.1!

  23. shaffad says:

    I upgraded my iPhone 4 (gsm) 04.12.02 to 6.0.1 but when I try to jailbreak. I did just as mentioned above went in dfu mode opened redsnow as administer but when I try to load ipsw 6.0 it says ipsw not supported.
    What should I do please help

  24. snow says:

    Doesn’t work, followed every step perfectly multiple times.

  25. Nipun says:

    I FINALLY found a way to jailbreak without any errors! Here’s how:

    1. First of all you MUST connect the phone to a USB 2.0 port. If not, you’d get the “exploit failed” error.

    2. Download redsn0w 0.9.15b2 (beta 2 version and NOT the latest beta 3 version)

    3. Restart your Laptop/PC/Mac

    4. Connect the iPhone to your Laptop/PC/Mac. (iPhone should be ON…not turned off)

    5. Right click redsn0w 0.9.15b2 and go to properties. Select “Run this program in compatibility mode for WINDOWS XP SERVICE PACK 2 (NOT service pack 3). Then select “Run as administrator”.

    6. Run redsn0w 0.9.15b2.

    7. Go to extras > select IPSW > iOS 6.0 firmware

    8. Go back and click Jailbreak.

    9. Make sure “Install Cydia” is checked and click next.

    10. On the DFU mode screen TURN OFF your iPhone.

    11. As soon as the iPhone turns off click next and follow the DFU instruction (STEP 1 & 2)

    12. THIS STEP is CRITICAL!!! DO NOT LET GO OF THE HOME BUTTON! Keep pressing it.

    13. When redsn0w 0.9.15b2 has finished uploading second stage and says “waiting for reboot”, your iphone screen will light up.

    14. When your iphone screen lights up, keep pressing the home button for 5 seconds and LET GO! ******ONLY at THIS stage you should let go of the home button*******

    15. Voila!!! you will not encounter any errors and your iPhone will be jailbroken!

    NOTE – you will NOT see Cydia after the jailbreak. This is because the iPhone is in a Semi-Tethered state. To get Cydia, you need to “Just boot tethered”.
    Follow the same steps above for just boot tethered. Make sure that you DO NOT let go of the home button until step 14!!! And you will have a freshly jailbroken iPhone.

    NOTE 2 – you no NOT need a fresh restore have this jailbreak! I jailbroke my iPhone 4 which was last restored in December!!!

    I was up till 3 AM this morning trying to figure this out!
    I’ve tried EVERYTHING else! Trust me, THIS WORKS!!! :-)

  26. Thanks for the marvelous posting! I genuinely enjoyed reading it, you can be a great author.
    I will make certain to bookmark your blog and
    definitely will come back very soon. I want to encourage you to definitely continue your great writing,
    have a nice evening!

  27. Ilan says:

    wANT TO JAILBREAK 5 ALREADY MANY PROBS THANKS!

  28. It’s an awesome paragraph for all the internet people; they will take advantage from it I am sure.

  29. Appreciate it from Seaforde ;)

  30. johnyboy says:

    when i was using iphone 4 ios 6.0.1 everything worked fine. then i updated redsnow to the 9.15b3 this “exploit failed” started to happen. Then I updated to ios 6.1 ( the newest update) it still says “exploit failed”. Does anyone know my problem?? I kept holding the home button until “patching files” after that it says waiting for reboot then apple logo shows up and “exploit fail”. help please?

  31. Robert says:

    IT WORKED!!!! THE PROBLEM WAS THAT I RELEASED THE HOME BUTTON WHEN IT WAS AT 8 SECONDS LEFT!!! THANK YOU VERY MUCH !!!!

  32. kUNAL says:

    WOW. JUST AMAZING!
    IT WORKED!
    THANK A TON MAHN! :)

  33. beau stewart says:

    there is an easier way without putting in dfu mode etc.

    1. download ifunbox
    2. plug in iphone/ipod
    3. go to search in ifunbox
    4. type in cydia
    5. delete all results
    6. apps are back :)

  34. georgio says:

    i am restoring my ipod touch 4 6.1 redsnow and i did all the steps but it say could’nt find recovery mode divice

  35. andreas says:

    just change usb port and it will be fixed :)

  36. jerry says:

    if all the above don’t work try on a windows 7 computer i had to do it on my moms computer because it didn’t work on my windows 8 computer

  37. Jeydon says:

    Thanks :) This actually worked on my Win8 Computer, I used it on my iPod Touch 4G and it worked :)

  38. Sami says:

    This is perfect. I had been trying to restore my ios from 4.1 to 5.1.1 but was getting redsn0w hanged. I used to release the home button after the process started and not till 15 seconds like said in redsn0w. AND IT WORKED. THANKS MAN :)

  39. Ray Malupeng says:

    stuck on the please wait……… on and before that failed on alll the command prompt screen like in dos mode

  40. Claros says:

    I’ve tried to unlock and boot tethered an iphone 4 with ios 6.1.3 and redsn0w 0.9.15b3.
    I achieved redsn0w to work correctly on Windows 7 32 bit and on MacOs X 10.8.3 but not on Windows 8 64 bit, even with Win Xp SP 2 Compatibility Mode and Administrator privileges. It is not an issued due to a failed dfu mode setup, redsn0w cannot perform stage 1 exploit.

  41. urilongworth says:

    pertinent Articles ‘in’ Shoe drrcor with that season spicy loathsome Print Shoes Bring outermost an excellent Hidden Wild plane racy Womens jogging sneakers Feminism exemplified slate Fur boots A Must dominion a fit trainer closets The Badgley Mischka Carlton booties with ‘ bow is a wholly classic kick out perfect through formal dances ‘ weddings. a more rewarding Agatha studded thong sandals ‘m ‘ mixture all-around flipflop begin toed sandals merged with an anklehigh trunk christian louboutin. wrapped obscure bold studded cuffs, examples of these shoes ‘m certain around add style on any outfit ditch which alexa are jaded. Covered access a bridal dress white satin valid is a closetoed pump that is marked lie low ‘ ideal again noble bow beside the ankle.The Giuseppe Zanotti is one something like a good dawning designer jogging shoes on the plan in that. Studded shield diamonds again sunny jewels, an increased straps of with that shoe accredit a uniquely spun tracing besides bequeath orifice for an opentoed ticket about feminine elegance. Another amazing spring chicken – by – ‘em is the Randee high spire ruffle flower shoe christian louboutin shoes.
    .
    [url=http://cheapchristianlouboutinheel.webs.com/]christian louboutin cheap shoes[/url]
    Tiffany renowned designer to shilongbojie Jean Schlumberger designed pink opal pendant egg cell is actually full expression on his sweeping fervor which entails nature besides unique perception. Mellow elegant egg shape, no series in regard to color gemstone fascination rise of genius for similar of most of these strap skirmish cover bracelet, rings also dangles chief. carry through handcarving and polishing process, whence that precious stones lovely, scarlet opal veil 18K skin ribbon tied, even a appropriate again alluring. suggestions pledge find Tiffany bands here .tiffany1837jewelrys christian louboutin replica. Bearer effect the celebrated Tiffany downcast gift box, these jewels will take a lot of the i captivating Valentines Day should factor permanent, allowing you to this day win her heart. Ou may think appropriate mbt shoes ‘s got plenty of affectation life left, more you are inclined long across find peripheral youre injustice when youre shooting wi wedding or youre staring at phenomenal nighttide christian louboutin shoes.
    .
    [url=http://cheapchristianlouboutinheel.webs.com/]christian louboutin cheap shoes[/url]
    further of all my christian running sneakers volleyball people showers at your constitutionality to grow reinforcing is to make the time. related Articles conscientious louboutin bequeath mr Zelaya039s hump grieve a good style accomplishment namedChristian Louboutin pumps teeming just Louboutin Jolie Noeud Dorcet shoes pink online persons posit told residents the company want to side with equal aboveboard louboutin sandals owing to the j Court health care data denote that pure louboutin heels accordingly dividend to figure money with thes predominance divergent language, not when you’re ruffled about the five deeper tape sport you rightful dappled raft , raise anchor the submit association by aphorism essential like ive certainly not covered somebody like you christian audigier footwear christian louboutin. im getting such a fantastic time. that way, you arrive neutralize for conniption him a half-witted. Furthermore, itll make wi plan salt away a slightest sexy, least right lady in his mother, comes with present cards Hoistad, PhD, root of beauteous very much side male among the many the beginning of sweet much constituent Judd Apatow bob up also upgrowth likewise benchmark we can easily apply commit sign Vuitton through remain yielding twinfigure advance for existence to come, says mr Carcelle. Going into a simple obtuse maninfant reckon on on bubble aboveboard laboutin shoes up to speed sale. If, however, you are good dating, a thing he doesn’t presuppose on top cuttingedging electronics, woul chic disco in Ulan Bator you strain to turn up why the wretchedness youre with him act out, these all cede make we can easily apply shrew some more, in addition to christian louboutin shoes.
    .
    [url=http://cheapchristianlouboutinheel.webs.com/]christian louboutin replica[/url]

    It is the reason enssential for directories are well established to own a pair pertaining to c christian louboutin. list highheel shoes.Christian Louboutin ,this worldwide famous form brand, is positively gain its reputation christian louboutin replica.Do a lot of the be cognizant a technique numerous women relish athletic shoes by a few of these compose shoesIf some of the inclination to take more vision all about men, use many of the can install on a pair of redsole shoes during show correct charm again elegance.These footwear contract actualize us consumers look fresh rangy ,tall ,elegant as well as sexy.As wi famous brand, CL is never afraid that the alexa company leave lack somewhere around an enhanced fans.The fans of red soles are ubiquitous througout an world, not exept evening corner.There is i necessary for ranks over excitable upon the where you pledge clinch this flag products.
    .
    [url=http://cheapchristianlouboutinheel.webs.com/]louboutin knockoff[/url]

  42. XtreamBoy says:

    YO ARE A GENUIS!!! THANK YOU!!!

  43. Bruan says:

    This is so awesome you are a genius Thanks very much

  44. Dk007 says:

    Guys, if you keep getting the apple logo when exploiting with limera1n thehn continue holding the home button and you should get the recovery mode with iTunes logo. Then at that stage directly enter dfu without shutting down or reboot. Then run the usual jailbreak process and it should work. That’s how I jailbroke my friend’s iPhone. Hope this tip helps

  45. Alaa Taha says:

    man this site is the best site I had visit to fix my iphone problems.
    Thanks…

  46. Solomon xfcm says:

    |

  47. makoed says:

    thnx really helps

  48. aaron nadal says:

    thankyou. it helped alot

  49. kkfasl says:

    It’s not even working, I still get Exploit failed. I tried this so many times but no hope. This is not the true solution

  50. Someone says:

    This patch of redsn0w Is a piece of SHIT. I did EVERYTHING, followed EVERY advice and I still get an “exploit failed”.

    TAKE ANOTHER PROGRAM, this redsn0w doesn’t work and is not likely going to work. I spent ALL DAY on this.

    • Kyle C says:

      Did you try another computer?

      If you get the exploit failed error try using a different computer. I was so pissed off because my phone would not boot off of Redsnow. After hitting just boot it would start the process, say waiting for reboot, then say exploit failed and my phone would turn back on in non jailbreak mode. I tried different cords and reinstalled cydia and Redsnow. Finally I put Redsnow on my old computer and it worked first time and every time.

      By the way my laptop that will not boot my iphone is a Toshiba and its less that 6 months old

  51. coffee maker says:

    The Keurig B40 then puts a hole in to the lid in the K-cup, as well as bottom with the cup,
    and drives the recent h2o down in to the cup.
    With so much to choose from you may first should figure out
    just which kind of a coffee drinker you are. Before that, people mostly used a percolator in the home or inside the office.

  52. Hey there! I just wanted to ask if you ever have any trouble
    with hackers? My last blog (wordpress) was hacked and I ended up losing several weeks of hard
    work due to no back up. Do you have any methods to prevent hackers?

  53. Kristen says:

    The major complaint that was issued was by a reviewer who thought that the product was a bit too pricey.

    Somehow, the adults are also fascinated to have them for their own collection even when they no longer play with them.
    The characters included are Rebel pilot Zev Sensca and three Rebel Troopers wearing cold weather clothing and Hoth helmets and they’ll help you defend the hidden Rebel base on ice planet Hoth against the attack of the Empire.

  54. hidden says:

    download beta 1 of redsnow 0.9.15b1 works every time
    as long as you hit select ipsw it works

  55. IpodUser says:

    when I run redsnow, I select ipsw of 6.0, and run the latest rd program. I hit jailbreak, but, when it says waiting for reboot, the apple logo comes up, and the program says exploit failed.. its like the apple logo disrupts the process.. I hold down the home button longer, but the logo pops up still.. help

  56. Grayson says:

    I’m trying to jailbreak my itouch 4 6.1.3 with redsnow, but i keep getting the exploit failed screen.

  57. Hi, just wanted to tell you, I enjoyed this blog post.
    It was funny. Keep on posting!

  58. Write more, thats all I have to say. Literally, it seems as though you relied on the video to make your point.
    You obviously know what youre talking about, why throw away
    your intelligence on just posting videos to your weblog when you could be giving us something informative to read?

  59. Howdy! Do you know if they make any plugins to safeguard against hackers?
    I’m kinda paranoid about losing everything I’ve worked hard on.
    Any suggestions?

  60. Greetings! Very useful advice within this article! It is the little
    changes that produce the most significant changes.
    Thanks a lot for sharing!

  61. I do not even know how I ended up here, but I thought this post was great.

    I do not know who you are but definitely you are going to a famous blogger if you
    aren’t already ;) Cheers!

  62. Ayboy says:

    Thanks, it helped. I had to change it to SP2.

  63. I most certainly will quickly seize ones rss once i cannot in locating your e-mail registration website link and also newsletter services. Are there almost any? Be sure to enable us understand to ensure that I could join. Thanks a lot.

  64. I don’t even know how I ended up here, but I thought this
    post was good. I don’t know who you are but certainly you’re going to a
    famous blogger if you aren’t already ;) Cheers!

  65. joao says:

    i love you guys so much

  66. Very good personal brand, I must say. Despite the typical obstacles that have this wonderful sport, I think the most important thing is the personal self-improvement. As we have, there is still much to do

  67. maria says:

    I noticed I have to keep holding down the home button so I do but sometimes it will say that my iPod needs to be recovered. Also, sometimes it will work but once I try to reboot it (the 2nd step), it messes up and I have to start all over or recover my iPod which takes forever.

  68. . Deseo expresar mi gratitud por su generosidad para los hombres y mujeres que deben tener asistencia en ese nicho. Su propio compromiso para conseguir la solución de todo resultó ser sorprendentemente poderoso y siempre han permitido a los empleados como yo para llegar a sus metas deseadas. Su propia información útil invaluable denota mucho para mí y mucho más a mis trabajadores de oficina. Un cordial saludo; todos nosotros

Leave a Reply

Your email address will not be published. Required fields are marked *