How To Fix Missing keys.plist Error while Jailbreaking iOS 6.0.1

How To Fix Missing keys.plist Error while Jailbreaking iOS 6.0.1 - We have received many comments from our readers complaining about MISSING KEYS.PLIST ERROR while trying to jailbreak their iPhone 4, 3GS and iPod Touch 4G on iOS 6.0.1 one of our readers called Tmel4198 has created a step by step guide that helped many readers to solve their problem check below.

How To Fix Missing keys.plist Error while Jailbreaking iOS 6.0.1

Tmel4198 says:

For everyone with the MISSING KEYS.PLIST ERROR

Step 1: Exit redsn0w and turn off your phone and unplug it

Step 2: Plug your phone back in and then enter DFU mode without opening redsn0w yet.

Note: if you don’t know how to put your device in DFU mode check this link

Step 3: Once in DFU mode, find redsn0w on your computer, right click on it and take ownership/run as administrator!

Step 4: Open Redsn0w, go to Extras –>Select IPSW –> select the 6.0 IPSW.

How To Fix Missing keys.plist Error while Jailbreaking iOS 6.0.1

Step 5: Go back, Jailbreak! let it do its thing and install cydia and then once the jailbreak is done and phone booted on, turn off your phone.

Step 6: Exit redsn0w, unplug your device, plug it back in and put the phone into DFU mode! Open redsn0w!

Step 7: In redsn0w go to extras –>select IPSW (6.0).

Step 8: Extras –>Just Boot>> This is the only fix for the missing keys.plist error!! YOUR WELCOME!!! I SPENT SO MUCH TIME TRYING TO FIGURE THIS OUT

Thanks Tmel4198

486 Answers + Add Your Answer

  1. Osama ali says:

    Send me ios 6.0.1 unthterd jailbrek release date

  2. Phalgah87 says:

    Quick question. I understand all that and it makes sense but you said to select iOS 6.0 as the IPSW, iOS 6.0.1. I know it’s a stupid question but will this same procedure work with ios 6.0.1 or is there not a good JB for that version yet? I spend a long time trying to figure the iOS 6 versions and get nowhere fast and my phone usually gets stuck in recovery and is unable to be “recovery fixed” by redsn0w so I usually have iTunes restore then I start from scratch again. I always end up saying screw it and put iOS 5.1.1 back on again lol

    • Tmel4198 says:

      redsn0w only works with iOS 6, so once itunes updated your iphone to 6.0.1, redsn0w will use 6.0 to jailbreak but your device will still be on 6.0.1

    • Sure98 says:

      I’m wondering…. Can you send me a Download for the iphone 3gs 5.1.1 Blobs? I had waterdamage and cant restore. :(

      • Tmel4198 says:

        if you have water damage then why would you need blobs in the first place, and also you cant send blobs, they are specific to each device. no saved blobs no downgrading for you

  3. Bijay Thapa says:

    I have the same problem, and here is my question, I have already 6.0.1 firmware so do i need to choose the firmware manually?

  4. brock says:

    You must have the 6.0 firmware for your device!!! 6.0.1 firmware will come up in redsn0w as unsupported build…this tutorial is exact and works great….just did it on my gsm iphone 4….. thanks a lot!!! :)

  5. miklo says:

    Thanks mate for taking that time lol i wanted to throw my iPhone out the window ;)

  6. miklo says:

    noo nnooo waiit!!

    SSWEEEETTTT hahaha it works like a sharm =)))

  7. SLW says:

    Hi, whenever I click jailbreak it keeps saying “exploit failed” is there anyway to fix this?

    • miklo says:

      read again here and if u fail READ AGAIN!! WAhahaha

    • Tmel4198 says:

      follow the last step of entering DFU mode! hold home button for exactly 15 seconds until you see “uploading first stage” when the process starts to jailbreak or just boot. do not let go at 8 seconds when the screen changes and it starts doing the process, you must still hold for the 15 seconds

      • eob2000 says:

        No u don’t u can stop at 8 secs it works every time

        • Tmel4198 says:

          yes you do have to hold for 15 seconds if you get an exploit failed error, it all depends on how fast your redsn0w does the exploiting process, the reason it says to hold for 15 seconds is so you dont run into this error in the first place, i never said holding it for 8 seconds wouldnt work did i? no

    • Greg says:

      Try Turning off Anti Virus software…

  8. eastcow says:

    fuck yeh! Fucking sweeeetT!!!!! XD

  9. Tom Nogueira says:

    hello,
    I did as explained step by step, to identify the build but the error appears again.
    Someone managed to fix this problem?

    • Eric says:

      I had to do this on my PC instead. I tried on my Mac w/ Lion and could not get rid of the exploit failed message after trying multiple times. Worked the first time on the PC.

    • Tmel4198 says:

      HOLD HOME BUTTON FOR EXACTLY 15 SECONDS, dont let go when the screen changes at 8 seconds.. Folllowing the 3rd step in the DFU process

    • bogdan says:

      it doesn’t workkkkkk

      • Nipun says:

        @Tmel4198 @bogdan
        You need to connect the iphone via a USB 2.0 port and NOT a USB 3.0 port. Many laptops and new PCs have USB 3.0 ports, and Redsn0w is not compatible with USB 3.0 architecture. Try changing USB ports. Trust me, it worked for me. I’m gonna try again today with a friend’s iphone 4. I’ll confirm afterwards.

  10. Cody Meade says:

    If this is only for 6.0, then why the fuck does it say 6.0.1. Thanks for wasting my god damn time.

  11. Cesar says:

    I did this and it worked but now, I have no wifi or Bluetooth, what can that be?

  12. saeed says:

    tanx….fuck yeaaaaaaaaah…asheghetaaaaaaaaaam lamasaaaaab…

  13. Rod says:

    Heres a challenge: how would you fix this error if your power button is broken and the phone is stuck in a recovery loop?

    Cuz im stumped.

  14. Tmel4198 says:

    For everyone with the MISSING KEYS.PLIST ERROR
    1. Exit redsn0w and turn off your phone and unplug it
    2. Plug your phone back in and then enter DFU mode without opening redsn0w yet. DFU=(3 sec lock button, 10 sec home and lock button, 15 second just home button).
    3. Once in DFU mode, find redsn0w on your computer, right click on it and take ownership/run as administrator!
    4. Open redsn0w, go to Extras>>Select IPSW>> select the 6.0 IPSW.
    5. Go back, Jailbreak! let it do its thing and install cydia and then once the jailbreak is done and phone booted on, turn off your phone.
    6. Exit redsn0w, unplug your device, plug it back in and put the phone into DFU mode! Open redsn0w!
    7. In redsn0w go to extras>>select IPSW (6.0).
    8. Extras>>Just Boot>> This is the only fix for the missing keys.plist error!!

    Just an addition to any confusion as to why the just boot wont work after a successful jailbreak and lets say you install a tweak which require you to boot like winterboard! You must always go back and select the 6.0 ipsw every time you Just Boot because it will throw that ugly missing keys.plist error at you ,if not that, it just wont successfully just boot unless selected ipsw is 6.0

    • InvictusSoul says:

      Thank you so fucking much! I love you (no homo)

    • John Allen says:

      Truly, I am not exactly certain how you figured out the succession of events to make this possible. Still, it worked and I thank you. I had been trying sequences for a day and decided to downgrade to 5.1.1 which is so stable compared to the 6′s. However, like every good little geek after I downgraded I said there has to be a way for it to work. I know you wont say. But how did you do it?????????

      Thanks

    • Craig says:

      I am running into this problem after successfully installing jailbreak, rebooting successfully, installing winterboard, and now I can’t reboot…
      Do I need to be in DFU mode BEFORE opening redsn0w or can it already be plugged in and powered off, THEN start redsnow, select 6.0 IPSW and just boot? I’ve tried both ways but it seems that when I am already in DFU mode when I start redsn0w it doesn’t recognize/auto just boot as it did right after the JB :(

      • Tmel4198 says:

        i do not understand what you are asking, are you already jailbroken or not. You must backup everything and restore your phone before this will work

    • Raj says:

      I was having a MISSING KEYS.PLIST ERROR. Tried all the options available on google but finally your instructions worked for me.Thanks.

      Phone : Iphone 3GS
      ios : 6.0.1
      redsn0w_win_0.9.15b3
      IPSW (6.0) (6.0.1 had an issue on 12/02/2012. Do not try 6.0.1 until the issue is fixed)

      Perfomed jailbreak after upgrading my phone to IOS 6.0.1 .

    • CHris says:

      When I right click to “Take ownership/run as admin, I dont see that choice on my list. I have a imac os snow leopard. Any help? thx

    • omar f. says:

      I do have problems with jailbreaking my iPhone 3GS with 6.1.3
      How do I select iOS 6.0 as the IPSW? Please help me with instructions. Thank you in advance!

  15. XombeR says:

    Just to let everyone know; If RedSn0w shows an “Error” when you Jailbreak, then theres still nothing to worry about. Just keep following the steps and your iPhone will be Jailbroken.

    /XombeR

  16. Skwisgaar says:

    Well i just want to say thanks to my best friend he is a real good help… thanks Google for directing me to this page :D btw the jailbreak error was fixed as you discribed in your thread thank you very much.

  17. hawk says:

    Hi,
    I have factory unlocked my iphone through those ebay sellers 5 months ago. It was fine till yesterday. I updated to ios 6.0.1 and bam i cant activate my phone. I hacktivate it but now it says no service and finds no carriers ? Do you have any idea about it. I contact my seller he is checking the issue but please make a blog about how to fix no service issue about 6.0.1. Lot of people seems to have that problem.

    Thank you

  18. Billy Bob says:

    Worked great and all my jailbroken apps work, only problem is Cydia is not installed .. or not showing up .. any ideas (not a great problem at the moment, but would prefer it there) also seems that my cydia tweaks are not working i.e. android lock screen, sbsettings etc

  19. JonLondon says:

    Thanks a lot! it worked for me ;)

    JonLondon

  20. Daniel says:

    thank you, really, its worked

  21. Keon says:

    Thank you…..

  22. ross says:

    Quick fix for everyone! After jailbreaking just make sure to go back to extras, select ipsw and select the 6.0 file , just boot,dfu and voila problem solved! Worked for me and i needed to do nothing else! Apparently it needs the iOS 6 file to boot each time or you will get errors

  23. pooya says:

    Thanks man, it worked!

  24. ghassan abbas says:

    How to fix unsupported IPSW 6.0

    • Tmel4198 says:

      you must make sure you are downloading the correct one, a lot of the IPSW online arent labeled correctly for the specific iphone. iPhone 4 CDMA is iOS 6.0.1 3.3 IPSW

  25. Alex says:

    Thaaaaaaanx ! Well done !

  26. Bob says:

    Hi, I have a iphone 4 updated to ios 6.0.1 and I have a windows laptop. I downloaded the build,went into redsn0w, and into extra’s and into the IPSW but when i look for the iphone buld its just a file with more files in it that are empty. I have tryed downloading other ones but it keeps happening. When I download the iphone build its just a file I dont get the dice thing. PLEASE HELP!!!

    • Michelle says:

      I had the same problem because my ios6 file downloaded as a .zip file onto my pc. You will have to convert the .zip file to a .ipsw file and it will show up as the dice thing. You tube showed me how to convert a .zip file into a .ipsw file. Good Luck!

  27. InvictusSoul says:

    IT WORKED, HOLY FUCKING DUCK IT WORKED! I LOVE YOU BRO!

  28. Mike says:

    THANK YOU :) I was searching this solutions for weeks! thank you

  29. zig zag man says:

    i have a ipod 4g every time i keep trying to jailbreak it. it keeps saying missing keys then i download ios 6 firmware and it say your firmware is not supported with this version of redsnow thank you

  30. yuriardi says:

    you are awesome my man, keep working and makes everyone smile

  31. aaron says:

    cheers Tmel4198 good share, this solution worked for me. much appreciated

  32. Jase says:

    Thanks this worked awesomely!

  33. Daedricprince88 says:

    I did this on my iPod touch 4g and Cydia never shows up I did this many times and no Cydia help me plz do I have to restore it!!

    • Dukeion says:

      Same problem here, iPhone 4 GSM, followed all the instructions, repeated the process – no jailbreak.

    • Dukeion says:

      Just got it – don’t follow the ‘enter recovery mode’ steps. Just plug in every time with the device powered off and let Redsn0w walk you through the DFU entry.

  34. John says:

    I have an error when jailbreak my iphone 4 gsm with ios 6.0.1:
    after redsn0w uploading first stage, it shows the message ” exploit failed”. how can i fix it?
    p/s: my use port is 2.0 version and i have ran the program as administrator. someone helps me

    • Hesham Farghaly says:

      i think u made the first 5 steps and you are waiting your device to be jailbreaked ,, try starting with step 6 : openning redsnow while your device is in dfu mode and select extras>select ipsw>select restore 6.0>back>justboot !! i just made like you and same error occurs so give it a try !!

    • Tmel4198 says:

      create a DFU IPSW, Your phone is not in the correct power state

  35. Hesham Farghaly says:

    thanks alot !! very helpful

  36. jsdfh says:

    The just boot now says the exploit failed.

    • Tmel4198 says:

      hold home button for exactly 15 seconds on step 3 of entering DFU mode for just boot. dont let go at 8 when the process starts

  37. jsdfh says:

    This isn’t working at all!

  38. AbsInsideStomach says:

    i follow every step by my iphone doesn’t have cydia .. Need help !!

  39. Mohammad says:

    I still get no sim installed message
    any idea how i fix this issue and use the phone with any sim card

  40. itjim says:

    After 8 hours of trying and failing then just accepting i no longer had a jailbroken phone i came accros your post.
    15 minutes later i had back my jailbreak.
    follow it step by step it works a treat.
    if ever there should be a donate option this one deserves it
    many thanks
    jim

  41. Robyn says:

    it says error and such and tells me to “slide power off” but my ipod wont do it :(

  42. grelots says:

    THANK YOUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU

  43. sam says:

    i was running iphone4 on ios 4.2.1 Gevey sim and decided to update to ios 6.0.1 and for doing so i downloaded the above redsnow 0.9.15b3, open it and got to ”extras” then ”even more” then In DFU mode and on selecting no Baseband option ipsw 6.0.1 redsnow did some steps and final message was something like ”ipsw 6.0.1 no BB installed successfully” after that and till now my phone is on recovery mode and only it showing is an itune and cable sign on screen called ”recovery mode” and i dont know what to do. anyone can help?

    • Brylene says:

      it did that to me without all the fancy crap and it took a few tries but i held the home and lock button like i was restarting it then put it in dfu mode… try it. if it doesnt work sorry but it worked for me.

  44. XxTGameplayBadgerxX youtube says:

    Hey man! Thanks! This cleared everything up! I feel bad for the people who don’t know about this. Thanks bro!

  45. Zee says:

    just rejailbrake and justboot

  46. Brylene says:

    Oh my god. whoever that guy is, i love him lolz. greatest day ever!!!

  47. Jaleya says:

    Thank you!! I love it.works perfect i’ve been trying jailbreak for 4weeks now, love it. xx! ty

  48. zest says:

    Thank y0u…work on my 3gs (old bootroom) ……Prefect ./////great///
    Thank you…

  49. amber says:

    OMG THANKS A BUNCH

  50. wasim says:

    thanks bro

  51. norman says:

    I tried the step that you say but when i jailbreak and is already in the “waiting” mode suddenly it will turn off and booth to the old settings….please help somebody

  52. Umair says:

    Thank you so much brother. I have been working on it since last three days but all in vain. Thanks a bundle to you :)

  53. steven says:

    miens is still now WORKING !!!!!!!!!!

  54. steven says:

    dude this dont work at all wdf it says failed i follwed this instructions and still nothing why cant it just be a simple jailbreak

  55. Ms Scorpio says:

    Cydia will not load on my iphone for nothing go thru all the process and nothing is happening what can i do

    • Rafa says:

      Me too, MS Scorpio, but the cracked app’s work without Cydia.

      I only need that Cydia appears.

      I think that our Iphone are JB but for one reason the Cydia app can’t install or is hidden.

    • Rafa says:

      Hi, Ms Scorpio I solved the issue restoring the iphone and then repeating the process,

      Now! I have Cydia in my phone.

      Regards.

    • Firooz says:

      When I jailbroken my device, the cydia wasn’t there, I just repeated the boot option as provided above and the cydia appears after restarting my device. but you shall use <EXTRA \SELECT IPSW, and choose the ips 6.0, go back and just reboot when your device is in DFU mode.

      The last critical is the backup…. Applying backup wouldn't install your applications and saying unable to install (just popping every-time), you shall keep your device in DFU mode again and reboot then sync with iTunes and the things are the same as it was….
      My device is just charming lolz…

  56. sandra says:

    you saved my night….thank you very much

  57. deedee says:

    wow you guys this is amazing only one webside so far which actually helps fix missing keys error thank u thank u thank u i was looking for solution for a week now you’re best :)

  58. remko says:

    Yes Worked fine thx

  59. mehran says:

    Thanks man! You saved me.

  60. Lucas says:

    Thank you! You’re the best!

  61. chang soo says:

    Thanks i can jailbreak my iPod with no cydia in it!

  62. Ami Iverness says:

    Unbelievable how easy this was. After countless hours..It took me seconds. YOU ROCK!

  63. Firooz says:

    Hey man, your valuable time for spending on this useful tutorial is really appreciated, its really worked for me on IOS 6.0.1 with applying the ios 6.0 for the missing keys on iPhone 4 GSM,(A1332)
    My best wishes for you man…. GOOD JOB! KEEP THE WORLD ROCK!

    THANK YOU! VERY! MUCH!

    EVERYTHING IS OK WITH MY DEVICE NOTHING HARM

  64. Firooz says:

    And here are 1000000000000000000000000000000000000000000000000000000000000000000000 Thank you

  65. josssy says:

    i did it cydia stared appearing on my phone but redsnow doesnt want to reboot my iphone 4g?

    help plesaa :(

    • Tmel4198 says:

      please rephrase, do not understand what you are asking

      • Dov says:

        I’m experiencing the same issue. After I’ve installed the jailbreak, I try to “Just reboot”, which is the last step, but this doesn’t work. Redsnow just gets stuck on “Waiting to reboot”. Any ideas?

  66. jimmy says:

    Thank you so much, if there is an iphone god, you must surly be it :)))

  67. Stefano says:

    MINCHIA FUNONZIAAAA BMAAAAA

    YHEAAAA FUCKAAAAAAAAAAAAAA

    work like a charm!!!!!!

  68. Tony says:

    Thanks for the instructions. I got all the way to the last step where you select the ipsw file and just boot. It looks like its about to work and then the phone freezes at the pineapple and wont boot up. I am selling this piece of junk and looking for an iPhone with iOS 5.1.1. I never had any problems with that version.

  69. jono says:

    Ok im running ios 6.0.1 bb 06.15.00 on a 3gs
    i have redsn0w_win_0.9.15b3

    i followed every detail my result is exploit failed

    i have downloaded and attempted to use firmware : iPhone3,1_6.0_10A403_Restore

    after Jailbreak shows error but i ignore and keep following instructions…
    but same result exploit failed … as a side note if i try to open cydia on my phone it tries to open but closes straight away? any suggestions?

    • Tmel4198 says:

      must hold the home button for exactly 15 seconds and don’t let go when at 8 seconds the screen changes and shows the jailbreak or just boot process, depending on what your doing such as entering DFU, or Jailbreak, or Just Boot, you must hold the home button for 15 seconds following the last step in entering DFU

  70. Rodrigo says:

    It´s works perfect! Thanks a lot!!

  71. Les says:

    Just followed the procedure to the letter, and cannot believe that I didn’t get the Missing Keys.Plist error. Not only that, all the preinstalled apps like Safari are now working.

    Many thanks to Tmel4198 for all the hard work in solving this problem.

  72. doomjoshuaboy says:

    there is one problem when you turn off your device still got the jailbrake on and when you turn back on, it comes up with the apple sign and it turns everything back to normal but still got the jailbrake apps on it.
    so be sure when you want to put it back on just go to extras on redsn0w and just boot and it will get your jailbrake back

  73. Mike says:

    Thank you soooooo very much!!! I tried other sites instructions but this worked!!!

  74. Pete says:

    I LOVEEEEEEEEEEEEEE YOUUUUUUUUUUUUUU I ALMOST CRIED BECAUSE MY PHONE WASN’T WORKING!!!!! THANK YOUUUUUUUUUUUUUUUUUUUUUUUUU!!!!!!!!!!!!!!!!!!!!!!!!!!

  75. Tchouck says:

    I tried, and followed the steps exactly how you meant it to, Still doesnt work for me. I got further in the process till the pineapple logo, then it takes forever, then my phone just reboot back to normal without being jailbreak

  76. Ryan says:

    I tried this exactly multiple times and it hasn’t worked. i got passed the pineapple logo and got to the just boot step but then got the missing keys.plist error. I have fully restored my phone to factory settings with 6.0.1 firmware and dont know whats wrong anyone have any ideas?

    • Tmel4198 says:

      follow my instructions exactly, it will work

      • Tmel4198 says:

        must also download the 6.0 IPSW not the 6.0.1 because it jailbreaks the 6.0 but keeps your phone on 6.0.1! must also follow the just boot method and select the 6.0 IPSW every time before you just boot or you get the error again

  77. Akiris says:

    All of you who get exploit failed message, someone stated earlier that u need to hold for whole 15 seconds the Home button as stated in DFU tutorial. So dont enter DFU using iReb or smt like that. Just turn off your phone, start redsnow, select IPSW>select 6.0, go to jailbreak, select install cydia, click next and redsnow will guide u to enter DFU mode. in step 3 when 8 seconds are left, if u entered correctly DFU, when 8 seconds till end pops it will start working, DO NOT LET GO OFF HOME BUTTON, BUT KEEP IT PRESSED UNTIL U HEAR SOUND OFF AND ON FROM UR COMPUTER, THEN LET IT GO AND IT WILL START TO JAILBREAK. Im sorry for the caps peeps, but i was stuck on exploit failed error for like 2 hrs, until i read above about the 15 seconds holding home button step. after that worked like a charm from the first try.

    Hope this helps

    Akiris

  78. Tmel4198 says:

    keep it held until you see “uploading first stage”

  79. ben says:

    m still stuck at the pineapple. I also waited long time at the reboot. Have tried too many times already…may use snowbreeze instead.

  80. Siony says:

    Thank you! thank you! thank you so much! :) it worked! :))

  81. Vlad says:

    Thank YOU!!!!!!!!!!! Worked!!!!!!!!!!!!! Saved up so much time!!!!!!!!!!!!!!!!!!!!!!

  82. brusk says:

    cant find the firmware when it asks to select ipsw
    help!!

  83. Anferny says:

    Hey Tmel I’m getting stuck at the Waiting for Reboot screen after the second stage. I really don’t know what to do.

    • Tmel4198 says:

      1. Do a fresh restore.
      2. Run redsn0w as admin
      3. Follow the instructions at top of page^^
      4. When going into DFU mode make sure when your on step 3 you hold the home button for exactly 15 seconds and no less! when the screen changes at 8 seconds you still have to hold the home button. To be safe keep holding it until you see “uploading first stage” or “uploading second stage”
      5. This should help you get out of the stuck reboot because sometimes messing up DFU mode will put the phone into a recovery state or not on at all

      Hope this helps

      • Anferny says:

        Alright so somehow I got to the point where the jailbreak data was getting uploaded to my phone. The screen was black but the Ipod’s backlight was still on. Is that DFU mode? Because that was the one time it worked and all the other times my screen was black without the backlight on. Anyway, after everything was loaded the screen said

        Please Wait…
        Please Wait…
        Please Wait…
        Please Wait…

        Then I screwed something up somehow and started fresh by restoring the Ipod and trying it all over again. I know in your directions at the top it says to put it into DFU mode before opening redsn0w but even at that I’m still getting stuck at the Waiting to Reboot… after the second stage is complete.

        I’m still extremely confused as to why it’s not working. Even when I follow your steps perfectly it still gets stuck at the waiting for reboot screen. Any idea whats going on?

        • Tmel4198 says:

          It seems to be a problem with your phone or you are not entering DFU mode correctly which can cause lots of errors, what iphone do you have and what service

        • Tmel4198 says:

          try all over again and see if you can get past the waiting for reboot again because you did it once already. if you can get back to the redsn0w completing the jailbreak and rest takes place on the phone. when your phone is doing the:
          Please Wait…
          Please Wait…
          Please Wait…
          Please Wait…
          Just let it be and it should work.

          • Anferny says:

            It’s the 4g iPod actually haha. That’s what I meant when I said phone my bad. I’ll try this again and I’ll keep you updated. Thanks for the quick responses dude.

      • Anferny says:

        See this is what’s confusing me now, in the guide above you’re telling me to enter DFU mode before opening redsn0w but then you’re telling me to to hold the button down until step 3. That would mean I’d have to enter DFU mode after I open redsn0w right? Because if I enter DFU mode before it automatically starts the jailbreak process.

        Also when it’s telling me I’m missing the keys.plist it says my ipod is build 10a523, rather than the 10a403 which I’ve been uploading when I select my ipsw.

  84. Joe says:

    Thanks alot bro. Its work…

  85. Letícia says:

    Thank you so much!!!!

  86. MsSasha says:

    *T*H*A*N*K* *Y*O*U* *M*U*C*H*A*S* !!!!!!

  87. Vikki says:

    I did this and it all worked but its saying i have “No Service” now =/

  88. Thipax says:

    Thankkkkks

  89. leo says:

    sup everyone i have a problem with my iphone 4, it was unlocked on iso 4.0 and i update it on itunes and now is on iso 6.0.1 and when i turn on da phone needs to be activate and no service i try all those thing with redsnow i download the firmware 6.0.1 ipsw and i jailbreak after the white writing on my screen said error please help me out my email is leoionescu@ymail.com pleasee i need helpp :(

  90. Jadinzero says:

    i love you…………. I LOVE YOU WITH ALL MY HEART!

  91. oshop says:

    Woow. Thank you!. It was the solution that i was looking for..!!

  92. Beginner Veteran Jailbreaker says:

    Okay I’ll keep this simple, detailed, and quick. (my iPod is 6.0.1 updated)
    I followed specific instructions on an insanelyios.com video to jailbreak an iPod 4G. However, there were specific differences: his iPod was the “white version” which he didn’t mention any difference, but as I download an ipsw for mine, there are two different ones out there, iPod4,1_6.0_10A403_Restore and iPod4,1_6.0.1_10A523_Restore. I still don’t understand the difference except that when I select the 523 file, redsn0w says it’s not supported, but I have the latest version of redsn0w as well.
    Then I started over and followed the video again, but with the other ipsw, which is the 403. Everything worked perfectly except until I opened Cydia and finally downloaded Winterboard for themes. I rebooted my iPod after the download was finished and opened Winterboard, but it kicked me out every time I tried opening it, and so did Cydia and nothing was working. Took me several hours to finally have Cydia removed and my iPod restored to its backup. I also checked in my settings>about>version, which shows me it is 10A523. Where do I go from here?
    My iPod is a black 4G, 8GB, iOS 6.0.1, and version 523. I still have redsn0w and both ipsw files. Explanation is appreciated. Steps will be loved. Thank you.

    • Tmel4198 says:

      You use the 6.0 IPSW to jailbreak 6.0.1, it is shown in the instructions. you use itunes and update your ipod to 6.0.1 then download the 6.0 IPSW from this website (6.0 not 6.0.1)
      and then in redsn0w you select the 6.0 IPSW and click jailbreak, then when you go to just bott tou must go back and select the 6.0 IPSW everytime you need to reboot your phone or you get the missing keys.plist error

      • Tmel4198 says:

        the reason you use 6.0 and not the iPod4,1_6.0.1_10A523_Restore (6.0.1) is because redsn0w hasn’t been updated to support 6.0.1, your iPod will stay on 6.0.1 it just needs the 6.0 IPSW to jailbreak it. Once you get it jailbroken, you must turn off the phone and in redsn0w extras, select the 6.0 IPSW again and then go back and click “Just Boot” when entering DFU mode make sure in the last step where you hold the home button for 15 seconds to not let go when the screen changes at the 8 second mark, you keep it held until you see “Uploading first stage” or else you will get an exploit failed error

  93. Lindsay says:

    Thanks so much!!!!

  94. nunod75 says:

    Hi people, could someone help me please. I do all the steps with success, but at the end, Cydia doesn’t appears!!!! Why is this happening to me??? What i do wrong??? The apps that i get with the older Cydia, they work, but i can’t have Cydia. Help me please!!!
    Best regards

  95. Tmel4198 says:

    Then you didnt do all the steps, after you jailbreak you have to select the 6.0 IPSW and Just Boot the phone so cydia will appear because it is tethered jailbreak.

    or

    you forgot to check mark “install cydia” when the screen shows up after clicking on jailbreak

  96. KP says:

    This version of redsnow didnt support,&( i already have redsnow verison 9.15b3),,when select the IPSW..plz get me out of this error,,

  97. Jacob Freeland says:

    Thank you!!!!

    I was so scared, but this worked!!!!

  98. FR says:

    Nice Work!
    Thank you very much !!

  99. Hadee says:

    This didn’t work. Still got same error. Help please?

    • Tmel4198 says:

      you have to follow instructions perfectly, it does work.

      1. Make sure you have latest redsn0w and that you have the correct IPSW which is the 6.0 and not the 6.0.1.

      2. Make sure you are entering DFU mode correctly before you plug your phone in, remember that the last step of the DFU process (3rd step) that you hold the home button for 15 or more second)

      3. Try again and again it will work

  100. Quang says:

    It works perfect.

    Thank for sharing :)

    Thanks,
    Quang

  101. CArlos says:

    I can’t thank you enough!!!!!!

  102. hazza says:

    i need help someone i dont have a ipod restore thing on step 4 i NEED HELP

  103. sunlite says:

    thanks Tmel4198,

    works perfectly this way :)

    best regards

  104. TeruiRyu says:

    before jailbreak must restore the phone?

    • Tmel4198 says:

      well it basically restores your phone in the first place and ya if you dont want to run into erros, it always works best with a fresh restore

  105. Calvin Kong says:

    Before jailbreak the iphone, the iphone must be restore?

  106. BVN says:

    THANKS ALOT MAN!!! <3

  107. Kenny says:

    Thanks man! This finally worked for me.

  108. Alex says:

    Thanks! it really helped me :D

  109. Saam says:

    Worked like a CHARM and its the only way to fix this problem … the most important thing in this procedure is that you must Select IPSW 6.0.0 instead of 6.0.1 (even if you have firmware 6.0.1 installed on your device)and for the starters you must come out of DFU then turn your device off For Jailbreak(Step 5) and Just Boot (Step 8) Section (No Shit Sherlock!!)
    And Mr.Tmel4198… You Sir is Kinda Out There !!

  110. THE DUMBASS -.- says:

    HEY I REALLY NEED HELP
    I HAVE THE IPHONE 3GS I HAD IT JAILBREAK BEFORE BUT I WAS SO STUPID THAT I UPGRADED TO THE VERSION IOS 6.0.1 AND NOW IS ASKING ME FOR A SEEM CARD BUT INSTED OF A SEEMCARD I WANT TO JAIL BREAK IT BUT I CANT FIND THE FILE IPSW REALLY NEED HELP THANKS I BEEN HERE FOR WEEKS

  111. Brian Stef says:

    THANK YOU I APPRECIATE IT

  112. THE DUMBASS -.- says:

    CHILL THE HECK OUT WHAT HAPPEN TO CYDIA????
    I DID CLICK INSTALL CYDIA

    • Tmel4198 says:

      so first you cant find the IPSW, you cant spell SIM card correctly and now you are saying no cydia?

      man follow the damn instructions

  113. mike says:

    hey man can you please help me i do all the steps right when ever i install cydia its says exploit failed how can i fix this problem ?

    • Tmel4198 says:

      You are not entering DFU mode correctly, you must hold the home button for 15 seconds or more on the last step (step 3) even though the process starts at 8 seconds, keep on holding your home button till you see “uploading first stage” or “uploading second stage”! That is how you get passed the exploit failed process.

  114. M says:

    DUMASS – get off the capslock if you want anyone to help you…

  115. Snark says:

    I’m doing something wrong here. I get all the way through it successfully (seemingly) and the very last step after the tethered boot gives me a pineapple on the iPhone (4) screen that just stares at me for 10 minutes before eventually rebooting normally with no Cydia installed.

    I’ll try again from zero, but I may just wait for an untethered JB solution for ios6. Can’t see where it went foul – it looked like it was going to work there for a while…

    • Tmel4198 says:

      restore and rejailbreak is your best bet, something went wrong. a lot of peoples phones are doing that for some reason and i’m sorry to say their is no actual solution, but that sometimes the phone wont boot up correctly with the pineapple

  116. Antonio says:

    For “Step 3″, How do I “take ownership/run administrator???” Thanks so much!

    • Tmel4198 says:

      if you have windows 7 just right click on it and you will see both those options, or just right click and go to properties>compatability>run as admin (check mark it) its at the bottom

      • compgeek says:

        Hello I have downloaded the firmware but I cannot find the ipsw file. Also, after downloading the firmware when I am extracting the files, I get an error after it has successfully extracted that iPhone2,1_6.0_10A403_Restore does not exist.

  117. mosivili says:

    Hello!
    Can anyone help me?
    iPhone 4 during jailbreaking do never endng Please wait…
    Thanks a lot!
    William

  118. John says:

    I did everything step by step. I put it in DFU mode and jailbroke it. I saw the RAM disk and all the codes. Then it turned on and I turned it off. Put it into DFU mode and rebooted it with redsnow. But it took 20 minutes to turn on and when it did it didn’t have cydia. Help me please! What should I do?

  119. Ketan says:

    Thanks Man..
    it was worked…

  120. nicoleta says:

    so i tried to jailbreak my iphone 3GS with Iphone2,2_60_10 and i got the missing key…. now im gone follow the steps that it’s written on this website with iphone3, 1_60_10…… hope it will work :(

  121. mhoefling says:

    Tank you very very much

  122. albert says:

    Apple é uma merda!!!!

    Isso não funciona!!!
    Ja tentei DFU várias vezes e nada!!!

  123. Nick says:

    This is the only page where i found an answer to this problem!!! Thx!!!!!!!

  124. Nyaaannnn says:

    …i…love…you… xD <3

  125. latte says:

    I have done everything in here and it still gives me the Missing Keys.plist error. Is that because every time i select the ipsw file it tells me “That IPSW is not supported by this version of redsn0w.”

  126. glenn says:

    hi, i open redsnow and select browse ipsw’s and i open my firmware file but i dont see the logo with iphone2,1_6.0…
    i see three more files (all_flash, dfu and usr and they all lead to redsnow saying no items match your search. can u help?

  127. nunod75 says:

    That’s not fair!!!
    I do all the steps correctly, even the 3rd step i stay 18 secs, select the iPhone3,1_6.0_10A403_Restore firmware, all seems to be perfect, all my app’s work fine, so it is jailbracked, right? But after the last reboot………… no Cydia!!!
    Where the hell is it???

    • Jeff says:

      After the jailbreak, Did you:
      1. close out redsn0w
      2. unplug your phone
      3. power your phone off
      4. set your phone in to DFU mode
      5. restart redsn0w in adminstrator mode
      6. reselect the ipsw file (iphone3 1_6.0_10a403_restore.ipsw)
      7.and then click just boot

      if you did, then cydia will show. Remember, this is a tethered jailbreak. No untethered jailbreak has been offered (expected Dec 22 2012)

      ??? let us know.

    • Tmel4198 says:

      Yes please let us know, Thanks jeff for helping

  128. thankyou says:

    i just wanna crawl into your ass, i fuckin’ love you. THANKS MATE

  129. RT says:

    THANK YOU !!!!!!!!!!!! YOU ARE MY HERO !!!!!!!!!!!!! I FINALLY GOT JAILBREAK ON 6.0.1 FOR MY IPHONE 4

  130. Val says:

    I’m stuck. I’m following the steps after I get the error, but when I get to the part where I’m suppost to select my ISPW, it automatically opens up to browse in my documents. There’s no firmware folder, or iOS 6.0 folder… I can’t find it anywhere.

  131. James says:

    I downloaded the correct IPSW file however, there is not IPSW restore file in it labeled .IPSW? I have an iPhone 4 with 6.0.1.

  132. Backintosh says:

    A mac tutorial would be appreciated, as a few users of Apple’s phone have Apple computers.

  133. nando says:

    my iphone says error reboot and do a clean power off slide but my phone wont reboot its stuck on the little apple screen help

  134. Nicole says:

    I have done all the steps and my iphone 4 still won’t jailbreak. When it starts the jailbreak process it freeze up during the please wait and after about 40 mintues it reboot itself back to the apple screen. Then when I go to Just Boot it goes through the process but then it get freeze up on the pineapple screen. In another 20 mintues it goes back to the apple screen and I have no cydia. I have tried everything. I have reset my phone as a new iphone on itunes. I need some help I miss my jailbreak. I hate I upgraded my phone

  135. desperate says:

    holy sh0t this worked. thank u so much. if u were here, i’d kneel infront of u and suck u dick. thank u thank u.

  136. LUCAS says:

    THANK UUUU SO MUCHH!

  137. Clayton says:

    Cant find the IPSW thanks for nothing .

    • Tmel4198 says:

      YOU DOWNLOAD IT FROM THIS WEBSITE< you do not need to browse for your IPSW at all. That is not even part of the instructions. You download the 6.0 IPSW from this website and then select it in redsn0w from the downloads folder

  138. Batman says:

    Yo can I use 5.1.1 instead of 6.0.1?

    • Chan says:

      it depends on if you have saved up your SHSH for 5.0.1 or any other previous IOS version.

      • Heather says:

        how do I save and retrieve SHSH? I have an Iphone 3gs with IOS 5.1.something and I also have an Iphone 3gs and 4 with IOS 6.0.1 I hate IOS 6 and want IOS 5 on my other phones, how can I do it? Thanks a bunch for any help you can give!!

  139. f says:

    Thank you very much, I was trying to jailbreak it last month and it was a nightmare!

  140. Orian100 says:

    Hey i’m stuck at the select IPSW thing. when i try to select my IPSW its says that its not supported by red snow and i downloaded the redsnow IPSW for ipod touch 4G
    what to do??

  141. User says:

    Thankx a lot ! :)

  142. wazitoyea says:

    i need help after my iphone 4 ios 6.0.1 is done downloading jailbreak data it goes to black screen top to bottom saying please… Plz help me fix this problem

  143. Chan says:

    hey,I managed to jailbreak,however,I ran into this problem when I had to reboot it,what should I do in this situation?

  144. Carlos says:

    Thank you so much @Tmel4198 and you,
    you saved my iphone 4, great tutorial, did it twice and got it to work, God Bless you guys!!!! happy holidays!!

  145. Spencer says:

    On my windows 7 i have downloaded the firmware but it dosent show up in any of the folders when i browse for IPSW and it is really getting on my nerve because my sister has IOS 5.1.1 and she used absinthe and i have IOS 6.0.1 and i have an ipod touch 4g please can you read my message and can you plaese answer as soon as possibe (ASAP) and also absinthe can you make a jailbreak for IOS 6.0.1 that would be alot easier and plus who has IOS 5.1.1 anymore unless they have rejected their idevice and please read this whole messege or i will become a noob and my sister will make more fun of me and i will get really angry and it will be very annoying for me so can you please read this entire fucking messege or my head will explode!!!!!!! :(((((

  146. S. says:

    Hello, I’m on iPhone 4.
    I’ve done everything you told in the tuto, but still, Cydia isn’t on my iPhone. What should I do?

  147. Jordan says:

    THANK YOU DUDE! I LOVE YOU, SPENT 1.5 HOURS TRYING THINGS AND THIS WORKED!!!! TY SOOOOO MUCH

  148. Peter says:

    Thanks, it worked

  149. BiggJJ says:

    Thanks name. So much.

  150. Brass says:

    Yesssss! Thank you so much! You have no idea how much grief this was giving me!

    • Arshiya says:

      Dont get too over excited and download alot of things and this can cause your springboard to crash and your IDevice will keep going into Safe Mode.
      This usally happens for iphone but i think it happens on ipod and ipad.

  151. Brass says:

    ok, so now I have a problem…the above worked and the phone booted up. It had been in recovery loop because I think maybe someone had tried to jailbreak before but given up. However, the Jailbreak instructions as above for the missing keys.plist error worked and the phone booted. It went to the ‘set up’ mode asking me to slide to set up. In the top left corner it says ‘searching’. After ‘sliding’ I select British English for Language and move to the next screen and select United Kingdom, then ‘set up as new iphone’ which takes me to the Apple ID page. I select ‘Sign in with Apple ID’ and I get a message telling me ‘Could not sign in. There was a problem with the connection to the server’ with an ‘OK’ button underneath, but the screen is frozen at this point. After a few seconds the phone turns off and reboots showing me the Apple logo and it takes me back to the beginning of the set up again. Pushing the Home button brings up the ‘Emergency Call, Start Again, Cancel ‘pop up’. If you leave this the phone tries to reboot. Any ideas anyone?

  152. Kata Györök says:

    Thank you sooo much!! :))

  153. Jesus Chavez says:

    Worked! Thanks!

  154. Jesus Chavez says:

    Worked, thanks!

  155. Michael zamora says:

    Hey i’m stuck at the select IPSW thing. when i try to select my IPSW its says that its not supported by red snow and i downloaded the redsnow IPSW for ipod touch 4G
    what to do??
    Also when I downloaded the IPSW 6.0.1 iPod touch 4g, it’s not that logo that looks like a (Lego), it’s a lot of files. Please!!!!! Help! Thank you

    • Tmel4198 says:

      It’s the 6.0 IPSW you must download; not the 6.0.1, the only thing that needs to be on 6.0.1 is your device, but the jailbreak process requires 6.0 IPSW selected

  156. Lanita Collazo says:

    I have tried everything for about an hour and I can’t get the ipsw to go away and jailbreak please give me some tips on trying to get this to work. Thanks:))

    • Tmel4198 says:

      select correct IPSW…6.0 IPSW can be downloaded from this site, make sure you choose the correct one for your device and not the 6.0.1 IPSW

  157. anna says:

    when i’m trying to do step 5, i get a massege asking if the iphon is old model or new. when i click old, it doest continue- it doest allow me to press “next”.
    what should i do? thanks!

  158. anna says:

    thanx ! it worked ! you r smart guy! I just would like to know how to fix the “searching” and “no service” problems… any idea ? thanx again !

  159. Canniboss says:

    I did everything you said, i have an iphone 4 running ios 6.0.1 an used a 6.0 firmware for redsnow but when it boots theres no cydia installed even though those white words showed up on the iphone screen.

    • Tmel4198 says:

      Then you did not do everything i said, you must boot tethered after the jailbreak for cydia to show up, in redsn0w click extras and select the 6.0 IPSW you used to jailbreak, then go back and click “Just Boot”..cydia will show up and you must do this process every time you reboot

  160. Lanco GH. says:

    Awesome! nice post is it! Thank you! Happy new year!!!

  161. Michael zamora says:

    Hi I downloaded IPSW 6.0 for my iPod touch 4g running 6.0.1 and when I select the IPSW it says “not supported”. What do I do???? Help please!!!! I also have redsn0w 0.9.15b3

  162. Shyamal says:

    is untethered jailbreak for 6.0.1 is available please reply me as my ios 5.1.19b208 was crashed and only one option was left with me of 6.0.1 i am facing problem when my phone get restarted some of the application doesnt work please reply me on my mail thank you my mail id is soni.shyamal@yahoo.com

  163. The Beast says:

    This is 100% working for my ipod touch 4g! Thank you sooooooo much!!!!!

  164. Arshiya says:

    I did all these steps and when it goes to that matrix script it start to say “please wait…” for about 15 minutes and the phon boots up without moving applications and installig bundles?

    PLEASE HELP

    • Tmel4198 says:

      Try these seteps:
      -Try a different USB.
      -Run redsn0w as Admin.
      -Restore your iDevice and start over
      -Follow all the steps precisely without any mess ups
      -Different computer

      if none of these work its the device itself

  165. Niklas G says:

    Thank you soooo much :)
    I was so worried about my phone.

  166. kartabya says:

    thankyou so much… this worked out very well for me..

  167. ambersource says:

    Thank you so much it fixed my i4!

  168. kristin says:

    thank you so much. pays to wait a month to jb when all possible problems/solutions have been found/fixed.

  169. jaskirat says:

    hey

    i just jailbroke my itouch 4g on 6.0.1 followed all steps ,nd installed semi unthered package ,nd then installed some tweaks
    -dash
    -blurriser
    -CK
    now my prblm is that cydia is not running full screen !!just 1/4 of the screen nd i also cheked enable battery %!! tried rejailbreak it says exploiting failed !!

    PLS PLS PLS help

  170. Dubber says:

    Little bit of advice if any one had windows 8 installed,been trying to jailbreak my 3GS with the latest version redsn0w and not working chucks up all kind of errors,back on windows 7 now (no problems)

  171. nic says:

    hi,thank so much!!!!!!!!workkk

  172. xXHiqhLifeXx says:

    Iphone 4 – ios 6.0.1

    Yesterday my iPhone was empty, so it shut down….since then I can´t boot it with redsnow(still trying Ibooty, but won´t work)

    When I select the IPSW 6.0 , redsnow said it isn´t supported yet :O
    It´ss the same IPSW like in their picture at the top. :0

    If i use Ibooty, it says `done:)` but my iphone screen gets black and stay black.

    (Its complicated to shut down the iPhone manuelly when its in a boot loop…most of the time it reboot after some secounds and i can´t set hardreset -.-

    what can i do ?

    Sorry for my bad english :):D i´m from germany :) if you know the answer or you want more info´s…write to my e-mail :) luttermann94@hotmail.de

  173. HR says:

    THank you so much!!!! Worked!

  174. santi says:

    Excellent worked like a charm!!!! Was going crazy for a while with this, thanks a ton.

  175. greg says:

    YOU ARE A GENIUS!!!! PERIOD, FULL STOP

  176. ismet says:

    Hi,

    since a few days I try to jailbreak my iphone4, but it’s not possible.

    I mean that I can’t get the CYDIA Button (Program) on my iphone4 (10A523).

    I followed all instruction from internet what I have to do to jailbreak my iphone4 that I get the CYDIA on my Iphone.

    I have done all steps via redsn0w.

    My Iphone had the FW 4.2.1 before. I upgraded to 6.0.1 (10A523)
    Modem Firmware: 04.12.02

    Until now I have get following error messsages:

    1.) …code signature for shared cache failed with erno=7

    2.) The last error message which I solved with your help here was:
    How To Fix Missing keys.plist Error while Jailbreaking iOS 6.0.1

    My Iphone4 starts up now again with 6.0.1 (10A523) but I can’t see CYDIA on my Ihone4.

    WHO CAN HELP ME.

    Thanks in advance

    • Tmel4198 says:

      When your done jailbreaking you have to, go into redsn0w and click extras, select the 6.0 IPSW you used to jailbreak with, then go back and select “Just Boot” ..this is because its a tethered jailbreak

  177. Krazyk says:

    Boom and that’s a fine fix!

  178. Callum says:

    on step 4 whenever i try it i cant find my ipod?? please help :)

  179. amir says:

    tnxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx… i love uuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuu..i done it

  180. ehsan says:

    successful installed jailbreak, when i choose IPSW and reboot my device (iphone 4) by redsn0w do not load my OS. what is the problem?

    • ehsan says:

      iphone 4
      iPhone3,3_6.0_10A403_Restore.ipsw
      redsn0w.exe

      after clicked just boot does not show my iphone dektop, only show loading page ( Apple logo with black bkground )

    • ehsan says:

      I reset factory my iPhone and again and again

      After the jailbreak, I did:
      1. close out redsn0w
      2. unplug my phone
      3. power my phone off
      4. set my phone in to DFU mode
      5. restart redsn0w in adminstrator mode
      6. reselect the ipsw file (iphone3 1_6.0_10a403_restore.ipsw)
      7.and then click just boot

      when it going to boot my system hang on in Apple log and does not load my iPhone desktop

  181. AppleSlize says:

    Thanks!!! Works:)

  182. melissa says:

    THANK YOU SOOOOOOOOO MUCH YOUR AWSOME!!

  183. John says:

    Ok, everything goes well til I have to select IPSW. I have a 3GS. I have downloaded the iPhone2,1_6.0_10A403_Restore file about 4 times now. When I goto the folder there is no IPSW file located within. In the Firmware folder, there are three folders: all_flash, dfu, and usr, and a file: ICE2.Release.bbfw. I have looked in every folder in the IPSW download and simply cannot find the file I need. Something is wrong with the file, or I’ve done something wrong. Please Help.

  184. Clau says:

    I did this and I got “exploit failed” :/

    • Clau says:

      Got it working eventually, holding home button throughout the process. I was going in DFU before but it wasn’t working and I did try holding the home button all along. Dunno what happened

  185. yop says:

    Man this is great !! just followed this quick guide and worked perfect ! yes
    thanks for sharing this method :D

  186. gaurab karki says:

    does this method support for those who want to preserve their baseband

  187. Janet C. says:

    YOU ARE THE BEST!

  188. liquid23 says:

    Been searching everywhere for this. Even wanted to revert back to ios 5 but just in time i found this.
    YOU ARE…..LEGENDARY

  189. rob says:

    10x! you unbricked my mate’s 3gs

  190. Monik says:

    Hola! tengo un problema y esque cuando pongo el firmware ios 6.0.1 de mi ipod touch 4g y lo intento poner en el rednow me aparece que cuadro que dice unsupported by this version of redsnow y el porblema esque ya lo hice con todas las versiones de redsnow y no funciona :/ AYUDA :( :( :(

  191. Grischa says:

    Thx alot!
    please Mary me!

    Greetz from Germany!

  192. Leon says:

    i was stuck on the pineapple logo instead of the apple logo then it went back to the apple logo?? ive searched the web and tried everything i can think of? any help?

  193. iso-jii says:

    got it working now thanks… just needed to press home button for few seconds longer… and the version is 6.0.1 (10A523)

    really great instructions

    -fin

  194. Salustiano says:

    Just came here to say it works on iphone 4 w/ IOS 6.0.1

  195. winston says:

    i’ve been doing every step listed above to the “T” to jailbreak with the correct 6.0 ipsw, and when my ipod touch goes to reboot the screen stays black. The status bar never stops and it never reboots. Please help!

  196. kashish says:

    hey! i’m using redsn0w 0.9.15b3 and whenever i select any ipsw it says ” that ipsw is not supported by this version of redsnow.
    how to make it work ! pls help

  197. Pelle says:

    Oh my GOD, I was about to smash my head againt the wall. THANK YOU!

  198. Cody says:

    how do i become adiminstrator or owner of redsnow?. im on a mac and when i right click on it i dont see any options like that. and also i have a broken sleep button on my iphone and i managed to jb it once and got this error. now the button doesnt work at all. anyway i just need to kmow how to open as an admin. thanks

  199. Cody says:

    ^^ nevermind got it!! you are truly a lifesaver!

  200. ft56 says:

    Thank you very much I was going throw my Ipod from the 10th floor.

    Worked on Ipod Touch 4th generation 6.0.1

  201. Cody says:

    to reboot do i have to rejailbreak it and do this process all over again???

  202. kariffa says:

    But if I do that boot off device and unplug device my ipod goes on when I plug it in again thats annoying

  203. Tony Stark says:

    OH MY GOD YOU ARE A SAVIOR. THANK YOU SO MUCH!!

  204. Erin says:

    Tmel4198, this fix worked for me!!! Thank you so much!!!

  205. khmer sokthy says:

    i am done well with this guide and this lesson, thank u so much

  206. Earl25 says:

    I tried jailbreaking my iphone 4(6.0.1 10A523)with the IPSW Iphone3,2_6.0_10A403..it says it’s downloading(with the pic of the hard drive and green arrow) and then I see all the small text and it gets stuck on “please wait”, but also gives me the missing key error. So I tried what Tmel said about the error and re-jailbreak and boot and the pineapple appears on the screen but once again is stuck and after a few mins of being stuck just goes back to reg iphone mode. I’m a first timer and know this is prob some stupid screwup on my behalf, but can anyone tell me where I’ve gone wrong with the jailbreak???

  207. Mike says:

    Just where do you find the 6.0 IPSW? its shows it under firmware but my PC doesnt point to this?

    • Mike says:

      sorry – im downloading it now from the website – the one marked for my 3GS is shown as iPhone2 etc not the IPhone3 in the above tutorial. Is that OK?

  208. DNA64 says:

    This is NOT the only way to fix this error :P
    You could do things the proper way an manually add the missing keys to the keys.plist file.

  209. James says:

    Can anyone help? I tried many times but it stuck at “Waiting for Reboot” and nothing happened with the iPod Touch 4 of mine. Now it won’t appear the Apple logo and i have to blinded DFU it up. Anyone ?

  210. Leon1355 says:

    Thanks :D

  211. lord anthony says:

    work for me thanks philppines

  212. jacob says:

    BRAV-FUCKING-O!!! :D

  213. Shaffad says:

    I upgraded my iPhone 4 (gsm) 04.12.02 to 6.0.1 but when I try to jailbreak. I did just as mentioned above went in dfu mode opened redsnow as administer but when I try to load ipsw 6.0 it says ipsw not supported.
    What should I do please help

  214. Greg says:

    I cant download the firware anywhere, PLEASE HELP ME ASAP! Email it to me please, my email is greg-hawkes@hotmail.com

  215. Ciro says:

    Redsn0w gets stuck on processing step after all of this steps, what should I do?

  216. Snoof says:

    I’ve tried this trick with my iPhone 4 on iOs 6.1 but just if the boot has finished my iPhone reboots normal with the apple-icon. Now its rebooting since half a hour. what should i do?

  217. Curley says:

    Tmel4198 you are a LEGEND!!!

  218. Josh says:

    after i boot it back up in tethered mode the correct symbol shows but there is no cydia anywhere on my device HELP!!!

  219. lewis saxby says:

    well done finaly it works full marks so happy thank you

  220. Chris says:

    Thank you so much! Worked like a charm!!!

  221. Zia Khan AfriDi says:

    thank you so much…it helps…GOD Bless you all

  222. John says:

    Im stuck at step 4

    where do I find the 6.0 IPSW?
    My computer just starts in my documents when I press “select ipsw” on redsnow and I have no idea where to look for the 6.0 IPSW.

    • John says:

      I didn’t open redsnow as administrator by the way, I have no idea how to do this. When I right click on redsnow icon, I’m not given the option to open as administrator?

  223. Capone says:

    Hi!,
    I have iPhone4 6.0.1(10A523) and i know that i must have firmware
    iPhone3,1_6.0_10A523_Restore.ipsw when i want to jailbreak my iPhone but i do not know where i can find this firmware PLS help.

  224. Tmel4198 says:

    I am no longer commenting on this thread. the iOS 6.0 – 6.1 Untethered jailbreak is out with the evasi0n tool

  225. xK1TT3NSUICIDEx says:

    It Worked finally someone who could fix a problem no one else could. THANK YOU!!

  226. Maheen says:

    Hey plz help me…I m badly stuck at a particular step…I have iPhone 3gs….I m not able to move after step 4…when I go to extras n click on select ipsw it says the ipsw is not supported by this version of redsnow even though I have the newest version of it…kindly help me…!!!

  227. erickauj says:

    thank you!

  228. agus widiana says:

    when redsn0w realese for iphone 4s
    because i want fix my iphone
    no carrir and signal streng

  229. ripparr32 says:

    I post this message to say Tmel4198 really thanx a lott!! For finding this solution!! Man i am also sitting 2 whole days, no sleep and then i find this solution really great. IT REALLY WORKS FOR ME. THX MAN!!

    For all the other people out there. I did it on the : iPhone 3GS, with iOs 6.1 (iPhone2,1_6.1_10B141_Restore)IPSW installed and using this method with iOS 6.0(iPhone2,1_6.0_10A403_Restore)IPSW. but you really must do everything exacelly how it’s written here, every step. Good luck byee.

  230. Tsetso says:

    Thanks !

  231. Joel says:

    I have the latest version of redsn0w but it wont boot the IPSW for my iPhone 4 (iPhone3,1_6.0.1_10A523_Restore) Any suggestions?

  232. Jhett says:

    Everything worked but when my phone turned on there was no cydia installed on my phone please help me.

  233. Jasmin says:

    when i go to “select IPSW” that ^^^ is not what appears. what do i do?

  234. Danny says:

    Thank you very much for this post! After having this problem with my iPod 4th gen this really helped me and after attempting these steps twice I got it to work. Thank you for all of your hard work and commitment

  235. mantwan says:

    how do you enter DFU mode without opening redsn0w

  236. Ben says:

    Where can I get the iphone2,1_6.0_10A403_restore.ipsw file from?

  237. Sephiroth says:

    thank you so much i have been trying to fix that for about 3 weeks now looked everywhere and it just does not seem to be anywhere elts even though it is such a simple fix

  238. c0nd1 says:

    ty. works perfectly.

  239. Agent B says:

    ILY <3 <3

  240. Thanker says:

    you sir, are a genius!

  241. Alaa Taha says:

    Thank you very much man, I had a big problem with this.

  242. Kalid says:

    hi have read all comments and everything but i have one problem when i put in the ipsm it says that it isnot supportive

  243. matthews says:

    Works on my iphone 3gs

    lot of thanks !!!!!

  244. Ayaz says:

    Hey

    Thanks it worked for my iphone 4 now its jailbroken on ios 6.1.3
    but when will an offical untethered JB will be out

    Thanks

  245. BigEBentley27 says:

    THANK YOU SO MUCH!!!!!!! YOU ROCK

  246. BigEBentley27 says:

    OH AND IT WORKED ON MY IPOD 4G ON IOS 6.1.3

  247. Joel says:

    Help!
    I get up to the step where I need to select my ipsw, I did that but when I go back and click jailbreak it says: Failed to decrypt kernel. What do I do to fix this?

  248. Catt says:

    THANK YOU SO MUCH!! It worked :)

  249. j says:

    THANKS THIS WORKS!!!!!!!! TOOK ME SO LONG.

  250. Dave Henderson says:

    Worked for me, I would never have figured this process out to correct the keys.plist issue. Thank you for not needing me to.

  251. Sergio says:

    Thanks a lot man! Worked

  252. Jackie says:

    OMG I would so love to say thank you even though I havent been looking how to do it longer then everyone else it so worked after one try. Thank you Thank you so much :) All the way from NEW ZEALAND :)

  253. Daniel says:

    Thank you soo much!

  254. Ronald says:

    hi can you please help me… i have an iphone 4 that wont turn on, was in singapore when brought it to cell repair and they told me that it needs to be (jailbrake/o)… I think i follow all the steps provided, i downloaded the lower version IOS 6.0 and also the redsnow… but when im on jailbreaking step it stopped on “uploading first step” i waited an hour to see if it will change but nothing happen… please i need your help. thanks

  255. HillyBilly says:

    hey can you help me after i set it on dfu mode and run the jailbreak it kinda crashes and is driving me crazy any help please ? :(

  256. Jogrhan says:

    It real worked!!!! Thanx man :-)

  257. spamepls says:

    wow finally something that works! thanks! iphone 4

  258. Alex says:

    OMG thanks dude you’re awesome

  259. umeme says:

    Thank you so much. I have been trying so hard and this really solves the problem!

  260. Samu Haber says:

    Thank you so much!!!! :-):-):-):-):-):-):-):-)

  261. Tyler says:

    YES!!! Thanks man youre the best

  262. mr nepal says:

    it worked, however i had request more time than the above procedure. thanks a lot…

Leave a Reply

Your email address will not be published. Required fields are marked *