How To Fix No Service issue iOS 6

How To Fix No Service issue iOS 6 ? on iPhone 5, 4S, 4, 3GS and iPad 3, 2 - No service issue After iOS 6 update is a public issue spread all over the web as a fire, we have received many emails regarding this issue and the ways to fix it we will show you in this post how to fix this issue.

How To Fix No Service issue iOS 6

Step 1: Go to Settings App

How To Fix No Service issue iOS 6

Step 2: Go to General then scroll down until you find Rest

Step 3: Go to Rest and Select Rest Network Settings then your device will inform you to enter your passcode

Step 4: Your device will inform you also by the message below then select Rest Network Settings

Note: take care Rest Network Settings will let you lose cause all your WIFI passwords,

Step 5: if the error still appears so its better to restore your device here’s the link that you will use

50 Answers + Add Your Answer

  1. Avnit says:

    You mean Reset,right??lol

  2. sbz says:

    i hv updated my iphone 3gs to 5.1.1 and after updating showing no service how can make it to the older version

  3. Orville says:

    it still says “no service” then “searching…” but i already inserted my sim and when i check the carrier it says my carrier.. help please.. :(

  4. Nawaz says:

    Try i-funbox. Its works. Go to File -> Preferences -> Enable Fast app install with AppFastIn(TM) Technology. And Install the App.

    Works Great. Finally Whatsapp on my iPad using Whatspad cydia tweak.

  5. Jim says:

    Cannot get past activate to get to settings any ideas?

  6. Mohammad says:

    After jailbreak ios 6 in my 3GS iPhone no service ???? Plz help me

    • epi says:

      hai,i can resolved ur n problem..i have one software

      • nitesh says:

        hi please tell me ..i am facing same issue… :( please helpp!!

        • partha says:

          Download and install redsn0w B3 in your computer.
          Run redsn0w in your systems with connected with iphone to your computer Via USB cable.
          Make sure you have download ios 6.0.
          Dont download 6.1.3.
          Open redsn0w click Extra and Add source of ios 6.0 & go back and Click just Boot and follow instruction

  7. Lou says:

    after io6 upgrade on my iPhone 3GS can not get 3g or E wifi works and so does phone

  8. Lou says:

    help after upgrading my iPhone 3GS to ios6 i cannot get 3g or voicemail

  9. julia says:

    It worked great! Thank you so much. I’ve been to the Apple store twice with this problem and they even gave me a new IPad. Both times they got my cellular to work again but it only lasted for a day to two. Hopefully, this fix will last.

  10. yahya says:

    i tried everysingle way to sort this problem out.
    i upgraded my mobile to 6.0.1 and i lost connections.
    no services is all i got at the moment.
    i even tried to contact apple and they seem very much relaxed .. they did not give a damn shit about my emails!

    really disappointed.

  11. Rob c says:

    Before ios6.0 and subsequently ios6.1 so called updates my iphone4 is crap, reduced wifi range, poor music playback volume reduced speed on pretty much everything, i used to love this phone but unless problems are resolved soon ,preferably with an option to go back to ios5.11 this will be my last idevice.
    Apple, listen to your customers, while you still have them !

  12. Diya says:

    Hello. My phone is completely unlocked and updated but I just can’t fix the No Service error. I’ve tried

  13. Sagar says:

    Same with me…I have unlocked the phone completely, but the No service error is not disappearring. It does recognize my SIM for 15 secs and then moves out of the network suddenly.

    Any expers to help on this ?

    • Vineet says:

      Hello Folks …yipeeee …!!!
      I was able to get out of this finally ” NO SERVICE / SEARCHING..” on ios 6
      3GS firmware – 6.0.1
      BB 5.13.04

      Steps :

      1) Cydia > SOURCES > EDIT > ADD > Enter Cydia / APT URL ” http://Repo.iparelhos.com/

      *Install ultrasn0w fixer for 6.0
      *Install ultrasn0w

      Once done , just restart using same JUST BOOT ” method using redsn0w ( redsn0w_win_0.9.15b3)

      If you get OR unable to open cydia Or if Cydia is crashing

      just use RedSnow 0.9.13 dev 4 (redsn0w_win_0.9.13dev4) for ios 6 .

      Steps :

      1. Run redsn0w file
      2. Go to Extras
      3. click on Select IPSW
      4. Select ios and open it
      5. Click on Just Boot
      rest is all I assume you shud e aware of …DFU mode n bla ..bla ..

      Plz let me know if it works

      Cheers!

  14. Jeroen Brussee says:

    Allrighty then!
    I’me dutch so sorry for my poor English..
    To make you’re iPhone find you’re simcard and find network again the solution is verry simple:
    When the phone is allready jailbroken do the following
    In redsn0w select the IOS 6.0.10A4** ipsw you use.
    Go back and select jailbreak
    Uncheck Cydia
    Check ipad baseband
    DFU and start jailbreak
    after done go to Cydia, install ultrasnow from repo.iparelhos.com
    reboot phone and it’s done.
    Cause of tethering, after battery fail or reboot, make shure you have Wifi. just go back to Cydia and reinstall ultrasn0w fo ios 6, reboot and done..

  15. Usman says:

    Hi every 1… Ios 6 have a common problem that no service , searching , no sim ….it should b easily fixed …GO TO SETTING
    GENERAL …press reset and select ERASE ALL CONTENT & SETTING…
    YOUR IPHONE REBOOTS…and activation screen appears..insert a sim.card.. Connect to wifi or pc to activate …..after activation …phone will b working fine …
    Thanxx

    • Zanje Zambia says:

      you are great my no service error is solved…thanks very much..this is what i followed …..
      GENERAL …press reset and select ERASE ALL CONTENT & SETTING…
      YOUR IPHONE REBOOTS…and activation screen appears..insert a sim.card.. Connect to wifi or pc to activate …..after activation

  16. Ahmed says:

    its working now after reset

  17. Ablant says:

    OPEN Redsn0w 9.15b3 go to extras select ipsw 6.0 and tick just boot tetherd right now install all limrAin reboot your phone
    and will be working fine if your problum solved please hit Thanks button

  18. usman malik says:

    hi guys i update my iphone 3gs from ios 4.1 to 5.1.1 and jailbreak it now iam facing issue my sim searching frequently and some times after long time i get full signals but then i can call for 1 or 2 times after that signals remain full but neither inccoming or outgoing calls go through neither able to send text message plz help me

  19. Muzaffer says:

    i have a 3gs ios 6.1…i use the operator vodafone in Turkey. When i have updated ios 6.1, it searches the operator and can not find it. Why Apple does not care this problem??? Million of people suffers because of this problem…

  20. zerald says:

    after update ios 6.1 by itunes on my iphone 3gs my iphone is not working help me.

  21. Joao says:

    Had the same problem with iOS 6.1.2 update on iphone5. Phone always showing searching for carrier but didn’t find it. Carrier support recommend me a restore, done it… and ended up with phone unrecoverable while iTunes always showing error (-1) and asking to restore again… I think people call the recovery loop.

    My carrier is Optimus (Portugal) and they unlock my iphone5 2 weeks after I bought it regarding their XMAS promotion. Had to sent phone to warranty :( This totally breaks my confidence in apple reliability… After ipod, imac, iphone3gs, macbook, macbook air… I’m totally disappointed with iphone5/ios reliability :(

    Joao

  22. jamal says:

    i have iphone 4 io6 recently i jailbreak it,,now i have carrier signals drop problem,,the signals bars goes up and down..what shuld i do now?

  23. Kosal Cambodia says:

    Fix no service for 3GS iOS 6+
    When finish restoring firmware open redsn0w /extra/ select iOS 6.0(only iOS 6.0)
    Back to jailbreak …
    Tick on Cydia and install iPad baseband / install…
    When finish go to redsn0w again and extra just boot in tether…
    Setup iPhone and open Cydia /manage/dev team/ultrasn0w
    Enjoy…

  24. Akshay says:

    After using cydia I do’t see my Carrier in my iphone 3gs setting help me to fix this

    • partha says:

      if the install cydia is working properly in your device Just do upgrade your cydia through by Wifi once cydia is upgraded to latest version. then you can find option of Ultrasn0w in cydia search and install that

Leave a Reply

Your email address will not be published. Required fields are marked *